Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.1.2 CE GA3, 6.1.30 EE GA3
    • Fix Version/s: 6.1.X EE
    • Labels:
      None
    • Environment:
      Linux Tomcat
    • Fix Priority:
      5
    • Similar Issues:
      Show 3 results 

      Description

      To reproduce this issue:
      1) New Liferay installation
      2) Go to Marketplace | Store
      3) Add a application that is > 3MB (ex: ETL process manager)
      4) Go to Marketplace | Purchased
      5) Click on download
      6) Download never ends

      To fix this issue:
      1) Configure portal-ext.properties and increase "dl.file.max.size" (ex: dl.file.max.size=30072000)
      2) Restart Liferay and retry.
      3) Works as expected

      I'm expecting the Marketplace app to show some warning / error to the end user to avoid confusion about why the download doesn't work.

        Activity

        James Falkner added a comment -

        I am upping the priority of this as many of the Marketplace plugins are greater than the default max size of DL uploads, so this will affect a great many first-time Marketplace users.

        Jorge Ferrer added a comment -

        Ryan told me by email that this should already be fixed

        James Falkner added a comment -

        Note that you can also adjust the max file size via Control Panel->Server Administration->File Upload and increase the max file size for documents & media (below the "general max file size" setting). This does not require a restart.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 47 weeks, 3 days ago

              Development

                Structure Helper Panel