Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-40473

The HTML tags <p></p> are always added to the message body, and this makes all of the contents written to the body field to be displayed as paragraphs.

    Details

      Description

      This issue still exists in trunk(6.2.x).

      Steps to reproduce:
      1. Add the following three lines to the portal-ext.properties file.
      editor.wysiwyg.portal-web.docroot.html.portlet.message_boards.configuration.jsp=tinymce
      editor.wysiwyg.portal-web.docroot.html.portlet.message_boards.edit_message.bb_code.jsp=tinymce
      editor.wysiwyg.portal-web.docroot.html.portlet.message_boards.edit_message.html.jsp=tinymce
      2. Click "Post New Thread" and choose to insert a picture into the body field. Enter a link to a picture on the Internet in the "Image URL" field.
      3. Publish the thread.

      The image should be displayed in the body field. However, no image is displayed and <p><img .../></p> is shown in the body field.

        Attachments

          Activity

            People

            Assignee:
            hai.yu Hai Yu
            Reporter:
            eric.cheng Eric Cheng (Inactive)
            Participants of an Issue:
            Recent user:
            Esther Sanz
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              7 years, 11 weeks, 1 day ago

                Packages

                Version Package
                6.1.20 EE GA2
                6.2.0 CE RC2