Details

    • Similar Issues:
      Show 5 results 

      Description

      Issue

      Portal displays error message, "You don't have permissions to view this page", when new user clicks "save" button on password reminder page.

      Test Case

      Test Objective

      Add new regular user.

      Test Steps

      Step 1/ Start Liferay Portal 6.2 CE RC3

      Step 2/ Sign in as admin user (eg. "test").

      Step 3/ Create new regular user

      • Navigate to "Control Panel > Users and Organizations"
      • Select link "Add > User"
      • Details:

      Screen Name: support.user
      Email Address: <your email address>
      First Name: Support
      Last Name: User

      • Click Save button
      • Portal displays message, "Your request completed successfully."
      • Click "Password" link and set default password of "pass".
      • Click Save button
      • Portal displays message, "Your request completed successfully."

      NOTE: New user has Regular Roles of "Power User (default)"

      NOTE: Password reset is required on first sign in.

      Step 3/ Sign out as admin user

      Step 4/ Sign in as new regular user

      Step 5/ Scroll to bottom of "Terms of Use" page and click "I Agree" button.

      Step 6/ Enter new password of "test".

      Step 7/ Enter Password Reminder details:

      • Question: test
      • Favourite question: test

      Click Save button.

      Test Outcome

      • Portal displays error message, "You don't have permissions to view this page".

      Test Status

      Fail.

      NOTE: The same tests applied to Liferay Portal 6.1 EE GA2 pass.

        Issue Links

          Activity

          Hide
          Robert Srisam-ang (Inactive) added a comment -

          Hey Tim,

          I downgraded my Windows 8 environment to Java 1.6.0_45. I was not able to reproduce the errors though. I'm using the Liferay Portal

          6.2 CE RC3 bundle (http://sourceforge.net/projects/lportal/files/Liferay%20Portal/6.2.0%20RC3/liferay-portal-tomcat-6.2.0-ce-rc3-20131003112222176.zip/download) with HSQLDB following the steps listed.

          Show
          Robert Srisam-ang (Inactive) added a comment - Hey Tim, I downgraded my Windows 8 environment to Java 1.6.0_45. I was not able to reproduce the errors though. I'm using the Liferay Portal 6.2 CE RC3 bundle ( http://sourceforge.net/projects/lportal/files/Liferay%20Portal/6.2.0%20RC3/liferay-portal-tomcat-6.2.0-ce-rc3-20131003112222176.zip/download ) with HSQLDB following the steps listed.
          Hide
          Stephen Kostas added a comment -

          I'm unable to test on Windows 8, but I'm seeing the same error on Mac OSX (with HSQLDB) using Liferay Portal Community Edition 6.2.0 CE RC4 (Newton / Build 6200 / October 11, 2013).

          Other than the general severity of this issue, it is a very serious issue for Training because 3 of courses use HSQLDB and would have students running into this error when they create user accounts.

          Show
          Stephen Kostas added a comment - I'm unable to test on Windows 8, but I'm seeing the same error on Mac OSX (with HSQLDB) using Liferay Portal Community Edition 6.2.0 CE RC4 (Newton / Build 6200 / October 11, 2013). Other than the general severity of this issue, it is a very serious issue for Training because 3 of courses use HSQLDB and would have students running into this error when they create user accounts.
          Hide
          Lawrence Lee added a comment - - edited

          Hey Guys,

          Just to bring some resolve to this issue. This issue occurs because of the lportal.script file found in the data folder. If the user deletes lportal.script before startup and allows Liferay to generate the data tables, the user will not run into this issue, this was the case being tested by Robert.

          I'm assuming Stephen and Tim tested out of the box and therefore did not delete the lportal.script before startup. This is the same issue as LPS-34237 which was closed as Won't Fix.

          I agree this is an issue we should fix, but the solution to this problem is much larger than the scope of this scenario. I'm going to close this ticket as Won't Fix for now. And i'll link this issue to any further discussion about the Sample data found in HSQL (most likely LPS-37300).

          Thanks for the participation regarding this issue.

          Please feel free to let me know if there are any other concerns.

          Show
          Lawrence Lee added a comment - - edited Hey Guys, Just to bring some resolve to this issue. This issue occurs because of the lportal.script file found in the data folder. If the user deletes lportal.script before startup and allows Liferay to generate the data tables, the user will not run into this issue, this was the case being tested by Robert. I'm assuming Stephen and Tim tested out of the box and therefore did not delete the lportal.script before startup. This is the same issue as LPS-34237 which was closed as Won't Fix. I agree this is an issue we should fix, but the solution to this problem is much larger than the scope of this scenario. I'm going to close this ticket as Won't Fix for now. And i'll link this issue to any further discussion about the Sample data found in HSQL (most likely LPS-37300 ). Thanks for the participation regarding this issue. Please feel free to let me know if there are any other concerns.
          Hide
          Stephen Kostas added a comment -

          I can confirm that removing the data directory before I start Liferay fixes the issue.

          Show
          Stephen Kostas added a comment - I can confirm that removing the data directory before I start Liferay fixes the issue.
          Hide
          Tim Telcik added a comment -

          Hello Stephen,

          6.2 CE RC3 is now closed and replaced with 6.2 CE RC4.

          Please look at related issues for 6.2 CE RC4 in ticket LPS-41230.

          Thanks

          • Tim
          Show
          Tim Telcik added a comment - Hello Stephen, 6.2 CE RC3 is now closed and replaced with 6.2 CE RC4. Please look at related issues for 6.2 CE RC4 in ticket LPS-41230 . Thanks Tim

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 46 weeks, 2 days ago

                Development

                  Subcomponents

                    Structure Helper Panel