Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-41293

User with Add Site permission requires additional permission to be able to add a site

    Details

      Description

      Steps to reproduce:

      1. Create a regular role with the following permissions
        • Control Panel > General Permissions > Add Site
        • Control Panel > Sites > Sites > General Permissions > Access in Control Panel
      2. Create a user (remove Power User role, and assign the regular role)
      3. Sign in as the user, and try to add a Site

      Expected result:
      Clicking add in the Sites portlet should allow the user to add a site, as the Add Site permission should be all that the user needs to add a site (6.1.20 behavior).

      Actual result:
      The Add button appears, but clicking it does nothing. Giving the user the Add Site Template permissions will allow the user to add a site, but this should not be the functionality.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              kenji.heigel Kenji Heigel
              Reporter:
              kenji.heigel Kenji Heigel
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 10 weeks, 5 days ago

                  Packages

                  Version Package
                  6.2.X EE
                  7.0.0 M3