Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.0 CE RC5
    • Fix Version/s: 6.2.0 CE RC6
    • Component/s: User Management
    • Labels:
      None
    • Environment:
      * Liferay Portal: Liferay Portal CE 6.2 CE RC5

      * O/S: Mac OS X 10.8.5

      * Java:
      ** Apple Java 1.6.0_35
      ** Apple Java 1.6.0_51
      ** Oracle Java 1.7.0_21

      * Database: MySQL 5.5.17
    • Similar Issues:
      Show 5 results 

      Description

      Issue

      Unable to change user profile image.

      Test Case

      Test Environment

      • Liferay Portal: Liferay Portal CE 6.2 CE RC5
        • "Liferay Portal Community Edition 6.2.0 CE RC5 (Newton / Build 6200 / October 18, 2013)"
      • O/S: Mac OS X 10.8.5
      • Java:
        • Apple Java 1.6.0_35
        • Apple Java 1.6.0_51
        • Oracle Java 1.7.0_21
      • Database: MySQL 5.5.17

      Portal EXT Properties

          jdbc.default.driverClassName=com.mysql.jdbc.Driver
          jdbc.default.url=jdbc:mysql://localhost/lp6120rc5?useUnicode=true&characterEncoding=UTF-8&useFastDateParsing=false
          jdbc.default.username=USER
          jdbc.default.password=PASS
      

      MySQL Database Schema

      create database lp6120rc5 default character set 'utf8' default collate 'utf8_general_ci';
      

      Liferay Portal Runtime System Properties

      java.home /Library/Java/JavaVirtualMachines/1.6.0_35-b10-428.jdk/Contents/Home 
      

      Test Steps

      1/ Sign in to Liferay Portal 6.2 CE RC5 as admin user

      2/ Create new user with default password

      3/ Navigate to "Edit User XXX > Details" for mew user

      4/ Click "Change" button under user profile image.

      Portal displays "Upload image page".

      NOTE: Image is blank by default.

      5/ Click Browse button and select image.

      Image can be PNG or JPEG of any reasonable dimensions (eg. 100x100, 250x300)

      Portal displays image with adjustable bounding box.

      6/ Click Save button.

      7/ Portal displays error message - "Users and Organizations is temporarily unavailable."

      8/ Test Outcome: FAIL

      Unable to change user profile image due to Java AWT error

      14:30:10,157 ERROR [http-bio-8080-exec-7][render_portlet_jsp:132] null
      java.awt.image.RasterFormatException: (x + width) is outside of Raster
              at sun.awt.image.ByteInterleavedRaster.createWritableChild(ByteInterleavedRaster.java:1270)
              at java.awt.image.BufferedImage.getSubimage(BufferedImage.java:1166)
      

      Tomcat Log Snippet

      14:12:04,213 ERROR [http-bio-8080-exec-9][render_portlet_jsp:132] null
      java.awt.image.RasterFormatException: (x + width) is outside of Raster
      	at sun.awt.image.ByteInterleavedRaster.createWritableChild(ByteInterleavedRaster.java:1270)
      	at java.awt.image.BufferedImage.getSubimage(BufferedImage.java:1166)
      	at com.liferay.portlet.portalsettings.action.EditCompanyLogoAction.getCroppedRenderedImage(EditCompanyLogoAction.java:205)
      	at com.liferay.portlet.portalsettings.action.EditCompanyLogoAction.saveTempImageFile(EditCompanyLogoAction.java:261)
      	at com.liferay.portlet.usersadmin.action.EditUserPortraitAction.processAction(EditUserPortraitAction.java:63)
      	at com.liferay.portal.struts.PortletRequestProcessor.process(PortletRequestProcessor.java:166)
      	at com.liferay.portlet.StrutsPortlet.processAction(StrutsPortlet.java:216)
      	at com.liferay.portlet.FilterChainImpl.doFilter(FilterChainImpl.java:71)
      	at com.liferay.portal.kernel.portlet.PortletFilterUtil.doFilter(PortletFilterUtil.java:48)
      	at com.liferay.portlet.InvokerPortletImpl.invoke(InvokerPortletImpl.java:618)
      	at com.liferay.portlet.InvokerPortletImpl.invokeAction(InvokerPortletImpl.java:649)
      	at com.liferay.portlet.InvokerPortletImpl.processAction(InvokerPortletImpl.java:312)
      	at com.liferay.portlet.PortletContainerImpl._doProcessAction(PortletContainerImpl.java:402)
      	at com.liferay.portlet.PortletContainerImpl.processAction(PortletContainerImpl.java:110)
      	at com.liferay.portlet.SecurityPortletContainerWrapper.processAction(SecurityPortletContainerWrapper.java:109)
      	at com.liferay.portlet.RestrictPortletContainerWrapper.processAction(RestrictPortletContainerWrapper.java:75)
      	at com.liferay.portal.kernel.portlet.PortletContainerUtil.processAction(PortletContainerUtil.java:115)
      	at com.liferay.portal.action.LayoutAction.processLayout(LayoutAction.java:356)
      	at com.liferay.portal.action.LayoutAction.doExecute(LayoutAction.java:178)
      	at com.liferay.portal.action.LayoutAction.execute(LayoutAction.java:79)
      

        Activity

        Mika Koivisto added a comment -

        Works with latest master (00cdc4a9b788eb66a347d630eaa0bea5c8833378)

        Edward Gonzales added a comment -

        Thanks Mika!

        Chris Dailey added a comment -

        This is an issue for me. I'm uploading it on an organization but it's the same for a profile picture. I'm guessing it's only specific images. Here is how to reproduce it, including an image that it happens with:

        1. Get this image: http://www.donwheaton.com/static/img/don-wheaton-logo-shadow.png
        2. Create an organization; edit the organization, and try to upload this image. After you select it and it shows up on the screen, click save and you get the message.

        My stack trace:
        21:39:02,893 ERROR [http-apr-8080-exec-43][render_portlet_jsp:132] null
        java.awt.image.RasterFormatException: (x + width) is outside of Raster
        at sun.awt.image.ByteInterleavedRaster.createWritableChild(ByteInterleavedRaster.java:1245)
        at java.awt.image.BufferedImage.getSubimage(BufferedImage.java:1203)
        at com.liferay.portlet.portalsettings.action.EditCompanyLogoAction.getCroppedRenderedImage(EditCompanyLogoAction.java:205)
        at com.liferay.portlet.portalsettings.action.EditCompanyLogoAction.saveTempImageFile(EditCompanyLogoAction.java:261)
        at com.liferay.portlet.usersadmin.action.EditOrganizationLogoAction.processAction(EditOrganizationLogoAction.java:66)
        at com.liferay.portal.struts.PortletRequestProcessor.process(PortletRequestProcessor.java:166)
        at com.liferay.portlet.StrutsPortlet.processAction(StrutsPortlet.java:216)
        at com.liferay.portlet.FilterChainImpl.doFilter(FilterChainImpl.java:71)
        at com.liferay.portal.kernel.portlet.PortletFilterUtil.doFilter(PortletFilterUtil.java:48)
        at com.liferay.portlet.InvokerPortletImpl.invoke(InvokerPortletImpl.java:618)
        at com.liferay.portlet.InvokerPortletImpl.invokeAction(InvokerPortletImpl.java:649)
        at com.liferay.portlet.InvokerPortletImpl.processAction(InvokerPortletImpl.java:312)
        at com.liferay.portlet.PortletContainerImpl._doProcessAction(PortletContainerImpl.java:402)
        at com.liferay.portlet.PortletContainerImpl.processAction(PortletContainerImpl.java:110)
        at com.liferay.portlet.SecurityPortletContainerWrapper.processAction(SecurityPortletContainerWrapper.java:109)
        at com.liferay.portlet.RestrictPortletContainerWrapper.processAction(RestrictPortletContainerWrapper.java:75)
        at com.liferay.portal.kernel.portlet.PortletContainerUtil.processAction(PortletContainerUtil.java:115)
        at com.liferay.portal.action.LayoutAction.processLayout(LayoutAction.java:356)
        at com.liferay.portal.action.LayoutAction.doExecute(LayoutAction.java:178)
        at com.liferay.portal.action.LayoutAction.execute(LayoutAction.java:79)

        I don't know if a comment is good enough, or if I should open a new bug.

        JR Houn added a comment -

        Hi Chris -

        It might be worth opening a new bug ticket, but it depends on some of the circumstances that surround the issue you are having. First - are you experiencing the bug on the same version as listed in the ticket (6.2 CE RC5?) Or are you experiencing it on the most recently released version of 6.2? If you're experiencing it on the latest version of 6.2, I would recommend that you go ahead and file a new ticket and cross reference it to this one - that will give us the best perspective and chance to assess your issue.

        thanks,
        jr

        Chris Dailey added a comment -

        Hi, JR Houn,

        I was getting the problem in 6.2 CE ga2. I just tried a fresh 6.2 CE ga3 and did not get the problem, so it may have been fixed. I see ga4 is now out, I'll try that when I can to make sure.

        Thanks for your help!
        Chris

        Chris Dailey added a comment -

        ga4 also worked fine. I suppose the only other possibility is if it only happens after a database has been filling up for a while, but based on the stack trace I doubt that's the case.
        Thanks again!

        JR Houn added a comment -

        Glad it worked - if you encounter it again on 6.2 GA4 please go ahead and file a new bug for the issue! Thanks for dropping by.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 week, 3 days ago

              Development

                Structure Helper Panel