Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-41756

Web Content Display portlet cannot display content from the scope of a different page

    Details

      Description

      Steps to reproduce:

      1. Add two pages
      2. Add a WCD portlet to each page
      3. On the first page, scope the WCD portlet to its page
      4. Add a basic WC through this first portlet
      5. On the second page, in the WCD configuration > scope, change the scope to the first page
      6. The Content will be available in the configuration: select it and click Save
        • A confirmation message displays, close the iframe
      7. Refresh the page

      Expected result:
      Content from the first page will be available and display in the second WCD, scoping to the first page.

      Actual result:
      Scope seems to update, and shows the content from the first page is available for displaying, but doesn't display. Also, when changing the Scope back to the Liferay Site (default for WCD), the portlet will say "The selected web content no longer exists." - as if it had been displaying the content in the first place. See attached screen record.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              brian.wulbern Brian Wulbern
              Reporter:
              brian.wulbern Brian Wulbern
              Participants of an Issue:
              Recent user:
              Marta Elicegui
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                7 years, 1 week, 6 days ago

                  Packages

                  Version Package
                  6.2.1 CE GA2
                  6.2.X EE
                  7.0.0 M1