PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-41807

Dockbar Notifications displays as a portlet that can be added to a page

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE RC6
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Labels:
    • Environment:
      Tomcat 7.0.42 + MySQL 5. Portal 6.2.0 RC6 GIT ID: a70f328d72613022e94f40f963a8b65d6a84b365.
      Plugins 6.2.0 RC6 GIT ID: 15123e9019925f9d740f8cd222a588a7735ec3fb.
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Fix Priority:
      5
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      1. Start up 6.2 without any previously installed plugins, besides marketplace
      2. Purchase the notifications portlet and install or hot deploy the portlet
      3. After installing, navigate to a page
      4. Click Add > Applications
      5. Search for Notifications

      Expected results:
      Only the Notifications portlet should appear

      Actual results:
      There is a Dockbar Notifications portlet that appears in an "Undefined" category. This does not occur on a bundles with preinstalled notifications portlets.

        Activity

        Jeffrey Yang added a comment -

        Changing to Fix Priority 5 as release is pending this ticket.

        Kenji Heigel added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5. Portal master GIT ID: 0064e693a44755e1756717d532719297b11ce8fa.
        Plugins master GIT ID: a585b882238aed0106a8132d7e09a5359ed2d631.
        Tomcat 7.0.42 + MySQL 5. Portal ee-6.2.x GIT ID: e3158198fe06b6824494342a8dccd7e33e78bd4c.
        Plugins ee-6.2.x GIT ID: f5eaf470b858db7e0dd2e2ef54962c36f4fc6aaf.

        In the Add > Applications, only the Notifications portlet appears. The Dockbar Notifications is not available in the Applications list.


          People

          • Assignee:
            Kenji Heigel
            Reporter:
            Kenji Heigel
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 23 weeks, 3 days ago

              Development

                Structure Helper Panel