PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-41876

On a mobile device, the dropdowns and dropdown icons for Calendar are not mobile responsive

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE GA1, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: UI Infrastructure
    • Labels:
      None
    • Environment:
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      1. Deploy the Calendar portlet and add it to a page
      2. Click the dropdown icon next to the calendar name

      Expected results:
      The dropdown icon should be bigger (as it's hard to touch on a touch screen) and the dropdown options should be bigger and responsive.

      Actual results:
      The dropdown icon is too small and is hard to select, and the dropdown is not mobile responsive.

        Issue Links

          Activity

          Kenji Heigel added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5. Portal ee-6.2.x GIT ID: 0cf2bf1661ae5428604b33853b76201c83b0a830.
          Plugins ee-6.2.x GIT ID: 88e90d2f7181dfd42dcd44c883fff5222a314811.
          Tomcat 7.0.42 + MySQL 5.5. Portal master GIT ID: 0cf2bf1661ae5428604b33853b76201c83b0a830.
          Plugins master GIT ID: 88e90d2f7181dfd42dcd44c883fff5222a314811.

          Tested on:
          iPod Touch
          Samsung Nexus 4

          The dropdown icons and menus are now mobile responsive. See the attached images for the changes.


            People

            • Assignee:
              Kenji Heigel
              Reporter:
              Kenji Heigel
              Recent user:
              Esther Sanz
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 4 weeks, 1 day ago

                Development

                  Structure Helper Panel