PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-42110

Space is removed among BBCode tags when switching to Source mode in Message Boards portlet

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.0.12 EE, 6.0.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Labels:
    • Environment:
      Liferay Version: 6.0 SP2
      Operating System: Windows 7
      Application Server: Tomcat 6.0
      Java Virtual Machine: Java 6
      Database: MySQL 5.1
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Epic/Theme:
    • Story Points:
      2
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Reproduction Steps

      1. Add Message Boards portlet to a page
      2. Type "text text"
      3. Add hyperlink to both "text"
      4. Switch to "Source" view (and back to WYSIWYG if you want)

      Result: The space between the two words disappeared.

        Activity

        Istvan Sajtos added a comment -

        The issue comes from bbcode_data_processor.js. The spaces are removed, because _isIgnorable function say that those nodes are not necessary. We should clarify which nodes can be indeed ignored and why.

        creol_data_processor.js is also affected by the issue.

        Iliyan Peychev added a comment -

        Spot fix will be provided to the client and I will work on this issue.

        Felix Zhang added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:
        Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: b9f1d4e55addfd9596fbc0ce660e606810261977.

        The space between the two words disappeared.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5.5.21. Portal ee-6.2.x EE GIT ID: ef1825f1968cd14c7cfc3aef41cac85f8b8c183b.
        Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: 9cc4997fe5920c162862c06686b88dd9549af70f.

        The space between the two words still exist.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 20 weeks, 4 days ago

              Development

                Structure Helper Panel