PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-42504

The editor format of Message Boards/Blogs will change after refreshing the page.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.20 EE GA2, 6.1.X EE, 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.2 CE GA3 , 6.2.X EE, 7.0.0 M1
    • Environment:
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      6
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      1. Login as admin.
      2. Add Message Boards and Wiki portlet onto the page.
      3. Click the Post New Thread button.
      4. Extend the Format, pay attention to the items under the Format.
      5. Click at the " This page is empty. Edit it to add some text.".
      6. Pay attention to the editor of Message Board, extend the Format, check the items under the Format again.

      Expected result:
      The editor of Message Boards should not be changed when the page refreshes.

      Actual result:
      Before the page refreshes, the editor of Message Boards has more formatting options and the list of format only has a few options (see MB_before.png). After the page refreshes, the editor of Message Boards will have fewer formatting options and a complete list of format (see AfterwithWikieditor.png).

      1. AfterwithWikieditor.png
        40 kB
      2. EditorChanged.gif
        2.77 MB
      3. MB_before.png
        54 kB
      4. OnlyMessageBoardeditor.png
        37 kB

        Issue Links

          Activity

          Albert Lee added a comment - - edited
          CKEditorUsecaseTestCase#testViewCKEditorsInheritanceNo
          com.liferay.portalweb2.enduser.userinterface.wysiwygeditor.ckeditor.usecase

          Test Result
          http://build-1/1/view/liferay-portal(ee-6.2.x)/job/liferay-portal-frontend-tomcat(ee-6.2.x)/label_exp=!build-1,test=CKEditorUsecaseTestCase%23testViewCKEditorsInheritanceNo/

          Tests run: 1, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 158.375 sec
          Test Writing Time: 3 hours

          Iliyan Peychev added a comment -

          Just started reviewing :)

          Sent from GH.

          Iliyan Peychev added a comment -

          Just started reviewing :)

          Sent from GH.

          Sharry Shi added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5.21 Portal master GIT ID: a0920d8ef97c928e2f101955df2a20813db13d89.

          The editor format of Message Boards/Blogs won't change after refreshing the page.

          Sharry Shi added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5.21 Portal ee-6.2.x GIT ID: c3773dfc462b485944088ef2e588885cb9669e11.

          The editor format of Message Boards/Blogs won't change after refreshing the page.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 12 weeks, 1 day ago

                Development

                  Structure Helper Panel