PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-42867

The quick edit popup and the edit dialog should choose the current resource site's calendar as the default one

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE GA1, 6.2.X EE
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Calendar
    • Labels:
      None
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      3
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      When creating an event, the calendar always selects the current user's calendar by default. However, it should the current's site calendar instead.

      See this post for details.

      1. fix.png
        33 kB
      2. reproduce.png
        41 kB

        Activity

        Marcellus Tavares added a comment -

        Just started reviewing :)

        Sent from GH.

        Hong Zhao added a comment -

        PASSED Manual Testing using the following steps:

        1. Start portal and login.
        2. Deploy Calendar Portlet on page.
        3. Try to add an event.

        Reproduced on:
        Tomcat 7.0.42 + MySQL 5.5.29 Portal ee-6.2.x EE GIT ID: f37193012facfff38f4a55549600b352dc6ff4b2.
        Plugins ee-6.2.x EE GIT ID: 582e84ef55b6f4224e621038a8dc1bc14123982f.

        When creating an event, the calendar selects the current user's calendar by default (reproduce.png).

        Fixed on:
        Tomcat 7.0.42 + MySQL 5.5.29 Portal master GIT ID: da90261cada65889263d4241cce944d06addd3fd.
        Plugins master GIT ID: 56cd7c174afbc8bf43179809a68220757402dc88.
        Tomcat 7.0.42 + MySQL 5.5.29 Portal ee-6.2.x EE GIT ID: f37193012facfff38f4a55549600b352dc6ff4b2.
        Plugins master GIT ID: f0303ea015e40edfb1e5387df213e07dfbaea207.

        When creating an event, the calendar always selects the current site's calendar by default (fix.png).


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 31 weeks, 6 days ago

              Development

                Subcomponents

                  Structure Helper Panel