PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43128

Template processing error occurred when set the Display Template to Color by Popularity in Tag Cloud portlet

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 7.0.0 M1
    • Component/s: WCM, WCM > Tags
    • Labels:
      None
    • Environment:
      Tomcat 7.0.42 + MySQL 5.5.29 Portal master GIT ID: 616d03f09a4981a36680e999deebcdad8d13d703.
      Tomcat 7.0.42 + MySQL 5.5.29 Portal ee-6.2.x EE GIT ID: 6ca5ac506ed52369cf72b96267d3ecd58cab87ba.
    • Story Points:
      5
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      1. Start portal and login.
      2. "Admin" > "Content" > "Tags" and add a tag.
      3. Back to liferay, add Tag Cloud portlet into page, press "configuration" button.
      4. Set Display Template to "Color by Popularity" in drop down list (change.png), save it.
      5. Close the pop up page.

      Expected result:
      No exception occurred.

      Actual result:
      1. Error message printed on screen (error.png).
      2. Exception occurred on terminal.

      05:43:01,615 ERROR [RuntimePageImpl-3][runtime:96] Template processing error: "Expression count is undefined on line 41, column 82 in 10157#10197#10430."
      
      Expression count is undefined on line 41, column 82 in 10157#10197#10430.
      The problematic instruction:
      ----------
      ==> ${count} [on line 41, column 80 in 10157#10197#10430]
      ----------
      
      Java backtrace for programmers:
      ----------
      freemarker.core.InvalidReferenceException: Expression count is undefined on line 41, column 82 in 10157#10197#10430.
      	at freemarker.core.TemplateObject.assertNonNull(TemplateObject.java:125)
      	at freemarker.core.Expression.getStringValue(Expression.java:118)
      	at freemarker.core.Expression.getStringValue(Expression.java:93)
      	at freemarker.core.DollarVariable.accept(DollarVariable.java:76)
      	at freemarker.core.Environment.visit(Environment.java:221)
      	at freemarker.core.MixedContent.accept(MixedContent.java:92)
      	at freemarker.core.Environment.visit(Environment.java:221)
      	at freemarker.core.ConditionalBlock.accept(ConditionalBlock.java:79)
      	at freemarker.core.Environment.visit(Environment.java:221)
      	at freemarker.core.MixedContent.accept(MixedContent.java:92)
      	at freemarker.core.Environment.visit(Environment.java:221)
      	at freemarker.core.IteratorBlock$Context.runLoop(IteratorBlock.java:179)
      	at freemarker.core.Environment.visit(Environment.java:428)
      	at freemarker.core.IteratorBlock.accept(IteratorBlock.java:102)
      	at freemarker.core.Environment.visit(Environment.java:221)
      	at freemarker.core.MixedContent.accept(MixedContent.java:92)
      	at freemarker.core.Environment.visit(Environment.java:221)
      	at freemarker.core.ConditionalBlock.accept(ConditionalBlock.java:79)
      	at freemarker.core.Environment.visit(Environment.java:221)
      	at freemarker.core.Environment.process(Environment.java:199)
      	at freemarker.template.Template.process(Template.java:237)
      	at com.liferay.portal.freemarker.FreeMarkerTemplate.processTemplate(FreeMarkerTemplate.java:122)
      
      1. liferay.2013-12-27.log
        35 kB
        Hong Zhao
      1. change.png
        22 kB
      2. error.png
        23 kB

        Activity

        Hong Zhao added a comment -

        PASSED Manual Testing following the steps in description.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5.5.29 Portal master GIT ID: a0920d8ef97c928e2f101955df2a20813db13d89.

        There is no exception occurred when change the display template to "Color by Popularity".

        Eduardo Garcia added a comment -

        This issue affects the provided sample template only, but not to the ADT functionality itself.


          People

          • Assignee:
            Eduardo Garcia
            Reporter:
            Hong Zhao
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 19 weeks, 6 days ago

              Development

                Structure Helper Panel