PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43212

Calendar - Saving Calendar Settings wraps Liferay instance in an iframe

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Calendar
    • Labels:
    • Environment:
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Clicking Save in the Calendar Settings dialog box wraps the Liferay instance within the iframe (please see animated gif).

      1. Click on one of the Calendars > Calendar Settings
      2. Click Save

      Expected Result:
      After clicking Save in the Calendar Settings Dialog box, the box should close and return to the original frame.

      Actual Result:
      After clicking Save in the Calendar Settings Dialog box, the box remains open and the Liferay instance is wrapped within the iframe.

        Issue Links

          Activity

          Marcellus Tavares added a comment -

          Caused by this commit:

          Commit: 10638b816c2d861c51dd10a4cdd54399d143b018 [10638b8]
          Parents: 7cc501c90e
          Author: Jonathan Lee <Jonathan.Lee@liferay.com>
          Date: December 11, 2013 at 10:23:42 PM GMT-3
          Committer: Brian Chan <brian.chan@liferay.com>
          Commit Date: December 12, 2013 at 1:01:05 AM GMT-3

          LPS-42790 Calendar - We should follow the standard with other portlets to open permission configuration in dialog when we can.

          Marcellus Tavares added a comment -

          Just started reviewing :)

          Sent from GH.

          Adam Brandizzi added a comment -

          It is the same PR as the previous one, except for having rebased more recent commits. Some pending tasks related to this bug are solved in LPS-43760.

          Marcellus Tavares added a comment -

          Just started reviewing :)

          Sent from GH.

          Sharon Choi added a comment -

          PASSED Manual Testing following the steps in the description.

          Fixed on:

          Tomcat 7.0 + MySQL 5. Portal ee-6.2.x EE GIT ID: 4e7c84374f77bd5ffcc6349513ebf3bfb0b98d26.
          Plugins ee-6.2.x EE GIT ID: 95e944c5e4fce4912816a3c0b3548b5f75359352.

          Tomcat 7.0 + MySQL 5. Portal master GIT ID: 174acf02a75cea5b65ee9ba882913f1d57925291.
          Plugins master GIT ID: 069b55b0371df1d9761287c85facb801f24de097.

          Saving the calendar settings no longer wraps a Liferay instance in the iframe. No errors appear on the console, and everything appears to be working successfully.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 19 weeks, 4 days ago

                Development

                  Structure Helper Panel