PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43225

The menu of staging extends past the screen width on mobile device

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 7.0.0 M1
    • Component/s: UI Infrastructure
    • Labels:
      None
    • Environment:
      Tomcat 7.0.42 + MySQL 5.5.29 Portal master GIT ID: 35120f110a6d52ea40eca936745cd365d165ca46.
      Tomcat 7.0.42 + MySQL 5.5.29 Portal ee-6.2.x EE GIT ID: c05563c02f36bb9e1c82c0e863920506b0bfcad9.
    • Story Points:
      3
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      1. Start portal and login.
      2. Enable Local Live from "Admin" > "Configuration" > "Staging".
      3. Visit portal on mobile device (iPhone 4s with original browser), press the "Staging" button.
      4. View in vertical and horizontal mode.

      Expected result:
      The menu of staging stays within the width of the screen.

      Actual result:
      The menu of staging extends past the screen width (vertical.png horizontal.png). Can be reproduced in the mobile preview of the portal in a browser.

      1. 43225_master_fix_horizontal.PNG
        46 kB
      2. 43225_master_fix_vertical.PNG
        65 kB
      3. horizontal.png
        43 kB
      4. Mobile_device_preview.png
        62 kB
      5. vertical.png
        57 kB

        Activity

        Haoliang "Lyon" Wu added a comment -

        PASSED Manual Testing following the steps in description.

        Reproduced on:
        Tomcat 7.0.42 + MySQL 5.5.21 Portal master GIT ID: 817f62e255ee45d23c8b4f3d1ae3795c0e90ad25.

        The menu of staging extends past the screen.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5.5.21 Portal master GIT ID: 230659d50264a50571d66f76afcefb7ad3adb85a.

        The menu of staging doesn't extends past the screen and aligns with the navigation's background.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 4 weeks, 1 day ago

              Development

                Structure Helper Panel