Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43298

Non visible assets are shown in Asset Publisher

    Details

      Description

      1. Add Asset Publisher and Blogs portlets
      2. Add blog entry 1 and blog entry 2
      3. Edit blog entry 1 and save as draft
      4. Click the blogs draft in AP

      Expected result:
      User should not see a redirect error.

      Actual result:
      As a user, clicking the blogs draft in the AP will redirect to an "The asset could not be found." error.

      After a deeper analysis, I've found that blogs logic is correct, and is setting the asset as visible only if the blogs entry is approved.

      The problem in in the Asset Publisher logic, that is showing non visible assets.

      This is reproducible the indexer enabled or disabled.

        Attachments

        1. 6.1.x.gif
          6.1.x.gif
          1.40 MB
        2. attachment.gif
          attachment.gif
          2.61 MB
        3. attachment.JPG
          attachment.JPG
          33 kB
        4. Guest_view.png
          Guest_view.png
          171 kB
        5. Master.gif
          Master.gif
          734 kB
        6. Master-140314.gif
          Master-140314.gif
          4.17 MB
        7. User_view.png
          User_view.png
          212 kB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 years, 10 weeks ago

                  Packages

                  Version Package
                  6.2.2 CE GA3
                  6.2.X EE
                  7.0.0 M1