PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43353

User without VIEW_BOOKING_DETAILS permission can see details of event

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.0.0 M3
    • Fix Version/s: 7.0.0 M1
    • Component/s: Calendar
    • Labels:
    • Story Points:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Given an event in a calendar where the guest user has not the "View Event Details" permission, the guest user can see some of the details.

      Steps to reproduce

      In a page containing the Calendar portlet

      1. Add a new calendar to the current site
        • To add a calendar, click on the arrow after "Current Site Calendars";
        • click on "Add Calendar"
        • after saving the new calendar, click on the blue arrow beside its name
      2. Click on the arrow after the new calendar name; click in "Permissions"
      3. If set, unset the "View Event Details" permission from the guest user.
      4. Click in "Save"; close the dialog.
      5. Click on the "Add Event" button
      6. In the "Details" section, select the newly created calendar.
      7. In the "Invitations" section, invite another resource.
      8. Click in "Save". Close the edit window.
      9. Log off from the portal.
      10. Click on the created event

      Expected results

      • In step 6, a success message would be displayed.
      • In step 7, the newly invited calendar would be displayed in the "Invitation" section
      • In step 10, a success message would be displayed.
      • In step 11, the removed calendar would not be displayed in the "Invitation" section

      Actual results

      • In step 6, an error message is displayed.
      • In step 7, the newly invited calendar is not displayed in the "Invitation" section
      • In step 10, an error message is displayed.
      • In step 11, the removed calendar is displayed in the "Invitation" section

        Issue Links

          Activity

          Adam Brandizzi added a comment -

          GIF showing how to create the calendar.

          Adam Brandizzi added a comment -

          GIF showing how to create the event

          Adam Brandizzi added a comment -

          GIF reproducing the bug

          Mark Jin added a comment - - edited

          PASSED Manual Testing following the steps in the description.

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: 9ad5275a8ed101b38f30b078031aa917ecaab637.
          Plugins master GIT ID: 069b55b0371df1d9761287c85facb801f24de097.

          Guest user can't see the details without the permission.

          Note: I can't reproduce the problem in Affects Version. It's because in affects version the calendar portlet failed to compile.


            People

            • Assignee:
              Mark Jin
              Reporter:
              Adam Brandizzi
              Recent user:
              Esther Sanz
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 18 weeks, 6 days ago

                Development

                  Structure Helper Panel