PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43515

Calendar Portlet Events do not display when Portal Context is changed from ROOT

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Calendar
    • Labels:
    • Environment:
      LIFERAY VERSION: 6.2 GA1
      OPERATING SYSTEM: Red Hat Enterprise 6
      APPLICATION SERVER: Tomcat 7.0
      JAVA VIRTUAL MACHINE: JRocket JDK 6
      DATABASE: MySQL 5.6
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      4
    • Fix Priority:
      4
    • Similar Issues:
      Show 4 results 

      Description

      Issue: Calendar Portlet Events do not display when Portal Context is changed from ROOT

      Steps to Reproduce
      1. Add portal.ctx=/portal in portal-ext.properties.
      2. Change ROOT folder name to portal in bundle\webapps.
      3. Change ROOT.xml name to portal.xml in bundle\conf\Catalina\localhost.
      4. Change <Context path="" crossContext="true"> to <Context path="/portal" crossContext="true">.
      5. Start server and go to localhost:8080/portal
      6. Place the Calendar Portlet on a page
      7. Create a new event in the Calendar Portlet for today
      Expected Result: The event is created and displays in the Calendar Portlet
      Actual Result: The event is created and does not display in the Calendar Portlet. But when I change the Portal Context back to ROOT, the event created in step 7 displays.

        Activity

        Marcellus Tavares added a comment -

        Just started reviewing :)

        Sent from GH.

        Shitian "Shelton" Zhang added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:
        Tomcat 7.0.42 + MySQL 5.5.34. Portal master GIT ID: 8ee7ae8bac9776333d141667cb263fc16cf36d06.
        Plugins master GIT ID: 59faf46633826bc2f94a03b8e8375519daf0d3a0.

        The event is created and does not display in the Calendar Portlet. But when I change the Portal Context back to ROOT, the event created in step 7 displays.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5.5.34. Portal ee-6.2.x EE GIT ID: 65453ccc6ad57a1cb7462bef69ce4924e62a1d49.
        Plugins 6.2.x EE GIT ID: dc22578871cc35d5cc6fef40306f8b5fb0dd9395.
        Tomcat 7.0.42 + MySQL 5.5.34. Portal master GIT ID: 96fed50978e6827b9dc4ea0e1038aa00f6353765.
        Plugins master GIT ID: 5574b6adc13ef642af9cb8388c7b8782a56a94a8.

        The event displays properly when the portal context is in both ROOT folder and portal folder.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 6 weeks, 4 days ago

              Development

                Structure Helper Panel