Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43546

Web content structures HTML field with hyphen in name property does not render

    Details

      Description

      Steps to reproduce this issue:

      1. On the Dockbar, navigate to Admin > Site Administration > Content.
      2. In the displayed Web Content page, navigate to Manage > Structures.
      3. Click Add, enter ‘Test Structure’ as the structure’s name and drag an HTML field into the grey area on the right.
      4. Configure the added HTML field, enter ‘test-name’ as the value of its Name property, and then click Save to create a new structure.
      5. Go back to the Web Content page mentioned in step 2 and click ‘Test Structure’ in the Add drop-down list.

      Excepted result: Should be able to add web content with structure test-name

      Actual result: You can not add a web content with structure with test-name and whole js will display on the end.

        Attachments

        1. Fixed.png
          Fixed.png
          144 kB
        2. Reproduced.png
          Reproduced.png
          109 kB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 years, 30 weeks, 6 days ago

                  Packages

                  Version Package
                  6.2.2 CE GA3
                  6.2.X EE
                  7.0.0 M1