PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-43716

Calendar asset renderer does not link to a view page when displaying asset links

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE GA1, 6.2.10 EE GA1, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Calendar
    • Labels:
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      3
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      When a calendar event is linked to another asset, and this other asset is displayed, the description of the calendar event is just plain text. There is no way of viewing the event.

      Steps to reproduce

      1. Create a page
      2. Deploy the calendar portlet in the created page
      3. Add an event in the calendar
      4. Create another page
      5. Deploy the blogs portlet in the created page
      6. Add a blog post in the blog. Save it
      7. Add another blog post in the blog
      8. In the "Related Assets" session of the blog editing page, click on "Select", then click on "Calendar Event"
      9. Select the previously created event.
      10. In the "Related Assets" session of the blog editing page, click on "Select", then click on "Blogs entry"
      11. Select the previously created blog post.
      12. Access the blog page
      13. Access the blog post

      Expected results

      1. Both the related event and the related post would be displayed as a link, which would point to a screen where more details about the event could be viewed.

      Actual results

      1. The related event is displayed as raw text. The related blog entry is displayed as a link, as seen in calendar-asset-link-no-link.png.

        Issue Links

          Activity

          Marcellus Tavares added a comment -

          Just started reviewing :)

          Sent from GH.

          Mark Jin added a comment -

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0 + MySQL 5. Portal ee-6.2.x EE GIT ID: 31c76842cc1b9981992827cb473a309698ca2924.
          Plugins 6.2.x EE GIT ID: 08fc50fbed1327400b654804939de81811240df1.

          The related event is displayed as raw text.

          Fixed on:
          Tomcat 7.0 + MySQL 5. Portal ee-6.2.x EE GIT ID: 31c76842cc1b9981992827cb473a309698ca2924.
          Plugins 6.2.x EE GIT ID: 6588cc7f395e1687941f9f66474c49ed87e7126c.
          Tomcat 7.0 + MySQL 5. Portal master GIT ID: 174acf02a75cea5b65ee9ba882913f1d57925291.
          Plugins master GIT ID: 6842c386105150e155f53ab5cc9bda3e5b865654.

          Both the related event and the related post displayed as a link.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 5 weeks, 3 days ago

                Development

                  Structure Helper Panel