Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-44239

OpenOffice will never generate a preview for a document file (Websphere)

    Details

      Description

      1. Setup a Websphere Portal instance with OpenOffice installed in the same machine.
      2. Start OpenOffice so it can be used by the server by navigating to OpenOffice's install directory then run this command:
        soffice -headless -accept="socket,host=127.0.0.1,port=8100;urp;"
      3. Login as an administrator or owner, go to Control Panel, then to "Server Administration" and click on "External Services," then enable OpenOffice to enable document preview, make sure the path is correct. Make sure to save.
      4. Go back to the home page or user home page, add the "Documents and Media" portlet (in a new page if desired)
      5. In the new portlet click Add, the click "Basic Document," upload a document file (an *.odt, for example), name it and click "Publish."

      Expected result:
      OpenOffice will generate a thumbnail for the document. When you click on the document, the document and all it's pages can be previewed.

      Actual result:
      No thumbnail is generated for the document. When you click on the document it says "Generating preview will take a few minutes." A preview is never generated.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  5 years, 9 weeks, 6 days ago

                  Packages

                  Version Package
                  7.0.0 M2