Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-44248

Images in DL do not survive "Publish to Live" if they exist before staging is enabled

    Details

    • Type: Regression Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.0 CE GA1
    • Fix Version/s: 7.0.0 M3
    • Component/s: Staging
    • Labels:
      None

      Description

      Steps to reproduce:

      1. Create blank site, add a single blank page
      2. Add documents and media gallery
      3. Add an image to the documents and media gallery
      4. Add a web content article to the page, and using WYSIWYG editor, choose the image from above for the content of the article. Click publish.
      5. Observe article shows image correctly.
      6. Enable staging
      7. Go to staging site, observe image looks correct, move a few portlets around, and publish to live
      8. Observe the image is now broken on the live site, and in its place a bad link like /web/test1/[$dl-reference=/group/26024/com.liferay.portal.kernel.repository.model.FileEntry/26037.xml$]

        Attachments

          Activity

            People

            • Assignee:
              evan.nagayama Evan Nagayama (Inactive)
              Reporter:
              james.falkner James Falkner
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 8 weeks, 3 days ago

                Subcomponents