Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-44337

Web Form portlet fails to validate checkbox fields

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 5.2.9 EE, 5.2.X EE
    • Fix Version/s: 5.2.9 EE
    • Component/s: Web Form
    • Labels:
    • Story Points:
      1
    • Fix Priority:
      4

      Description

      Steps to reproduce:

      1. Deploy "web-form-portlet-5.2.8.3.war" and start Liferay 5.2 SP4
      2. Place Web Form portlet on a page
      3. Go to the portlet's configuration
      4. Switch to "Form Fields" tab
      5. Add a new field and set its type to "checkbox"
      6. Go back to your page and fill out the form, but do not set anything for the checkbox
      7. Send the form, you will get an error message: "You have entered invalid data. Please try again."
      8. Fill out the checkbox as well, and attempt to send the form again

      Result: Although you will get the success message, the previously displayed error message is still present

        Attachments

          Activity

            People

            Assignee:
            sharry.shi Sharry Shi
            Reporter:
            zsolt.szabo Zsolt Szabo (Inactive)
            Participants of an Issue:
            Recent user:
            Esther Sanz
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              7 years, 43 weeks, 1 day ago

                Packages

                Version Package
                5.2.9 EE