PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-44380

Import/export of calendar events fail in event the parent event is not accepted

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE GA1, 6.2.10 EE GA1
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Calendar
    • Labels:
      None
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      7
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      To reproduce:
      (1) Create a resource (e.g. Meeting Room 303)
      (2) Create an event in a site calendar (e.g. Liferay) for the site, inviting both the site and the meeting room
      (3) Accept the event for the meeting room.

      However, parent event (e.g. the one in the Liferay site) is not accepted.

      Attempt to perform a site export. Note, this causes the export to fail because the parent event (the one in the Liferay site) is pending. Since the lar export picks up the resource's booking to be exported, it will also attempt to export the parent event (e.g. the one in the site). This causes a validation exception (BaseStagedModelDataHandler:250) because the parent event (a strong dependency) is not in an exportable status

        Activity

        Marcellus Tavares added a comment -

        Just started reviewing :)

        Sent from GH.

        Felix Zhang added a comment -

        PASSED Manual Testing following the steps in the description.

        Reproduced on:
        Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: e4300a8502ccf6f08a73e50927c3a0da83d46371.
        Plugins master GIT ID: 02926029a2602e7a53b7214add27dc6a21d7eefa.

        Fail to import/export the calendar event which parent event is not accepted, the console throws a error.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5.5.21. Portal ee-6.2.x EE GIT ID: 1125490f4b5a856a2cdab8ce2e9509b6842ce30d.
        Plugins ee-6.2.x EE GIT ID: 5684344c0cd4fbfef0927482d84fa9be38844ab3.
        Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: c13212783706c5b9b920b4619a1ebdc5da175eb1.
        Plugins master GIT ID: 62abb69d5fccfedca2c595aeea0acf3d66f1ed3e.

        Succeed to import/export the calendar event which parent event is not accepted, no error messages display in console.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 12 weeks, 4 days ago

              Development

                Structure Helper Panel