Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.0 CE GA1, 6.2.10 EE GA1, 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: UI Infrastructure
    • Labels:
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      4
    • Fix Priority:
      3
    • Browsers:
      Internet Explorer 7
    • Similar Issues:
      Show 5 results 

      Description

      IE7 does not handle trailing commas properly. This is a general cleanup to prevent potential issues in IE7.

      A usual error looks something like this:

      IE7 ... javascript error Expected identifier, string or number
      

      Regex used to find commas:

      ,[\s]*[^A-z0-9\s{_'[(!$*"\.\\</\-`#\%\+&]
      
      1. fix.png
        49 kB
      2. reproduce.png
        47 kB

        Issue Links

          Activity

          Hong Zhao added a comment - - edited

          PASSED Manual Testing using following steps:

          1. Start portal and login by IE 7.
          2. Admin > WC > Create a web content.
          3. Check the page if there is any js error.

          Reproduced on:
          Tomcat 7.0.42 + MySQL 5.5.29. Portal master GIT ID: 95e6c983f19eaeb9d49fb7b862fc17ffca348cf3.

          There is js error on page (reproduce.png).

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5.29. Portal master GIT ID: cc6150f5cfe1ada0168b9131bed7da59e6747881.
          Tomcat 7.0.42 + MySQL 5.5.29. Portal ee-6.2.x EE GIT ID:2c7a86b065f3ea5ee363a1265e33eef9a9c1f13b.

          There is no js error on page (fix.png).


            People

            • Assignee:
              Hong Zhao
              Reporter:
              Byrån Zaugg
              Recent user:
              Esther Sanz
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 3 weeks, 6 days ago

                Development

                  Structure Helper Panel