PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-44533

Javascript "TypeError: btnNavigation is null" displays in firebug when hovering over 'My Sites' from Admin > Content

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.0.0 M3
    • Fix Version/s: 7.0.0 M1
    • Component/s: UI Infrastructure
    • Labels:
    • Fix Priority:
      4
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      1. Navigate to Admin > Content
      2. Hover over My Sites in the top panel

      Expected result:
      User won't encounter script errors.

      Actual result:
      "TypeError: btnNavigation is null" is thrown (associated with line 316, "btnNavigation.setData('menuItem', navigation);" in the loaded script liferay-dockbar.

      Note: this happens when hovering over ANY of the dropdowns available to users in Admin > Content

        Activity

        Brian Wulbern added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0.42 + MySQL 5.5 Portal Master GIT ID: c9171da156079bf97fa0a14d12a01114b559eac7.

        JS errors are no longer thrown when hovering over the top dockbar.


          People

          • Assignee:
            Brian Wulbern
            Reporter:
            Brian Wulbern
            Recent user:
            Esther Sanz
            Participants of an Issue:
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 12 weeks ago

              Development

                Structure Helper Panel