PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-44629

On a recurrent events moving the start time of the first event of the series propagating to all followings generates duplicated events

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Calendar
    • Labels:
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      3
    • Similar Issues:
      Show 4 results 

      Activity

      Haoliang "Lyon" Wu added a comment - - edited

      PASSED Manual Testing following the steps in description.

      1. Deploy Calendar portlet and add to page.
      2. Add event and check Repeat Radio.
      3. Move the first event to other start time and select All-Following option.

      Reproduced on:
      Tomcat 7.0.42 + MySQL 5.5.21 Plugins master GIT ID: 08777e197ce9d4e58fb21fd924a9996f055386ae.

      At original start time, calendar add duplicated events automatically.

      Fixed on:
      Tomcat 7.0.42 + MySQL 5.5.21 Plugins master GIT ID: a0186520599965a26b3c43e80526b6dbefe729e9.
      Tomcat 7.0.42 + MySQL 5.5.21 Plugins ee-6.2.x GIT ID: b6ec65733d28f2d24bf252b21abe8bba4e28983a

      The All following option works normally and there isn't duplicated events.


        People

        • Votes:
          0 Vote for this issue
          Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:
            Days since last comment:
            1 year, 21 weeks, 5 days ago

            Development

              Structure Helper Panel