PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-44748

Calendar - Editing a recurring event and saving as "Only this instance" will propagate changes to all events in series

    Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Calendar
    • Labels:
      None
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Epic/Theme:
    • Fix Priority:
      5
    • Similar Issues:
      Show 5 results 

      Description

      1. Add Calendar portlet to page
      2. Add repeating event
      3. Edit repeating event
      4. Click save as "Only this Instance"

      Expected results: Only the event selected should have edited information.

      Actual results: All events in the series end up having edited information. NO errors appear on the console.

        Activity

        Adam Brandizzi added a comment -

        Just a note: this bug only occurred when the steps were applied to the first instance of the series.

        Marcellus Tavares added a comment -

        Just started reviewing :)

        Sent from GH.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 10 weeks ago

              Development

                Structure Helper Panel