Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-45234

liferay-ui:custom-attribute's values aren't set correctly in case of grouping types

    Details

      Description

      Reproduction steps:

      1. Create an expando field for the Blogs Entry:
      a) Go to Control Panel\Portal\Custom Fields
      b) Select BlogsEntry and Add Custom Field (Selection of Text Values)
      c) Edit it add default value /(true,false)
      2. Go to Blogs portlet and add a new blog
      3. Select value false on the custom select component.
      4. Try to publish

      Expected behavior: After reloading page the previously selected value (false) should be selected.
      Actual behavior: After reloading page the first value(true) will be selected.

      Note: This kind of bug is reproducible with other grouping types as well.

        Attachments

        1. fixed45234.gif
          fixed45234.gif
          276 kB
        2. LPS-45234-after-fixing.gif
          LPS-45234-after-fixing.gif
          643 kB
        3. LPS-45234-before-fixing.gif
          LPS-45234-before-fixing.gif
          1009 kB
        4. reproduced45234.gif
          reproduced45234.gif
          359 kB

          Activity

            People

            • Assignee:
              ian.song Ian Song (Inactive)
              Reporter:
              zsolt.szabo Zsolt Szabo (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 4 days ago

                Packages

                Version Package
                7.0.0 Alpha 5