PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-45399

When a user's timezone is not UTC, creating an All Day event in a specific way will make the duration over 2 days

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 7.0.0 M1
    • Component/s: Calendar
    • Labels:
      None
    • Epic/Theme:
    • Fix Priority:
      5
    • Similar Issues:
      Show 5 results 

      Description

      When a user's timezone is not UTC, creating an All Day event in a specific way will make the duration over 2 days.

      Steps to Reproduce
      1. Go to User's My Account -> Display Settings, and change the Timezone to any setting other than UTC
      2. Go back to any page and add the Calendar portlet
      3. Click in the gray box (All Day row) to initiate the creation of All Day events
      4. Click Edit
      5. Click Save
      You'll see that the event now spans 2 days instead of one.

      Note: Instead of Step 3, you can also use the "Add Event" button to reproduce the same behavior by checking the "All Day" checkbox.

        Activity

        Marcellus Tavares added a comment -

        Just started reviewing :)

        Sent from GH.

        Esther Sanz added a comment -

        Resolving it as it is already commited

        Sharon Choi added a comment -

        PASSED Manual Testing following the steps in the description.

        Fixed on:
        Tomcat 7.0 + MySQL 5. Portal ee-6.2.x EE GIT ID:
        2523b45ac251db71cdb328df8151132cc68534f3.
        Plugins ee-6.2.x EE GIT ID: aed7e8aecb02ff78de3f69626c2f476738441351.

        Tomcat 7.0 + MySQL 5. Portal master GIT ID: 890dbc046337ad0e353d05332babe97cd8d20b63.
        Plugins master GIT ID: a5781076e3616df73c9d2d5b15e3c084e5d552c8.

        Creating an All Day event will no longer make the duration of the event over 2 days. No errors appear on the console and everything appears to be working successfully.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              1 year, 14 weeks, 1 day ago

              Development

                Structure Helper Panel