Details

    • Fix Priority:
      3

      Description

      Unable to see translations for Japanese or other languages with special characters on portal. All translated text appears with "???" in varying lengths.

      Specifically with JBoss EAP 6.1 + Liferay 6.2 versions.
      When using Sybase 15.7 as the database, the log shows that characters are unable to be converted (see: http://pastebin.com/nxfP13Y2).

      Steps to reproduce:
      If using Sybase as database:

      1. Follow steps for 15.7 to set up db: https://in.liferay.com/web/global.engineering/wiki/-/wiki/Quality+Assurance+Main/How+to+use+Sybase+%28VM%29
      2. Follow steps in wiki to set up JBoss EAP 6.1: https://in.liferay.com/web/global.engineering/wiki/-/wiki/Quality+Assurance+Main/JBoss+EAP+6.1+Installation
      3. Make sure to change portal-ext to connect to sybase
      4. Start Liferay
      5. Add language portlet to page
      6. Click flag for Japanese
      7. Assert characters show as "???" (refer to attached image)

      If using MySQL as database:
      Follow above steps, omitting sybase set-up step.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Days since last comment:
                5 years, 13 weeks, 6 days ago

                Packages

                Version Package