Details

    • Type: Bug
    • Status: Closed
    • Resolution: No Longer Reproducible
    • Affects Version/s: 6.2.10 EE GA1, 6.2.X EE, 7.0.0 M3
    • Component/s: Calendar
    • Labels:
      None
    • Story Points:
      1
    • Fix Priority:
      4
    • Sprint:
      Sprint 09: Jan, 18 - Jan, 29

      Description

      RSSAction needs a null check in getEntryURLAssetPublisher(), or RSS link will not open correctly.

      Steps to Reproduce

      1. Add Asset Publisher to a page
      2. Add Web Content Article
      3. Click the Gear icon in Asset Published and select Configuration
      4. Under Asset Publisher - Configuration, leave the default settings and click on the Subscriptions tab
      5. Enable RSS subscription
      6. Save changes
      7. Open up a browser capable of reading RSS feeds (in my test I used Firefox)
      8. Click on the RSS popout link
      1. Nolonger62.gif
        227 kB
      2. NolongerM.gif
        208 kB
      3. Reproduced.gif
        421 kB

        Issue Links

          Activity

          mod David Kubitza added a comment -

          The problem is not the missing check. In my case assetRendererFactory is null, because it tries to find the renderer for the asset class CalendarResource which does not exist. So you have to fix the calendar portlet.
          Also, the null pointer check is nice anyways, I think, it's the wrong place. At https://github.com/liferay/liferay-portal/blob/553adad92d68c0ebd8ee4da73fa3d97d54775dc5/portal-impl/src/com/liferay/portlet/assetpublisher/action/RSSAction.java#L107 it's getting the URL. If you return an empty string, then add a check for it here and skip the asset or check for classname at the beginning of the for-loop. That way, other portlets can't trigger the same error as the calendar does now.

          adam.brandizzi Adam Brandizzi added a comment -

          Since there are no steps to reproduce, I could not see the problem happening, but it is vaguely similar to LPS-43713. Does this problem happens after updating a database from 6.1.x to 6.2.x?

          mod David Kubitza added a comment -

          Hi Adam, as you can see George added steps. Nethertheless the problem was descripted already well enough, even a pull request exists and my comment how to solve this issue!
          No portal updates, just install a 6.2 portal. Please follow the activities of this ticket and check out the links.

          George: You can fix it temporary by using an EXT plugin.

          adam.brandizzi Adam Brandizzi added a comment -

          Could not reproduce on master. If still reproducible, please reopen the ticket (and update the steps if necessary).

          harry.chai Harry Chai added a comment -

          No Longer Reproducible through Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0.42 + MySQL 5.6.10. Portal ee-6.2.x EE GIT ID: ab0bbc4141ed46f26244ba00eacf6b06993e53f2.

          RSS page is not right.

          No Longer Reproducible on:
          Tomcat 7.0.62 + MySQL 5.6.10. Portal master GIT ID: 8e30dc08bc8907084c48b7462ded417c2f25582c.
          Tomcat 7.0.62 + MySQL 5.6.10. Portal ee-6.2.x EE GIT ID: c8572d62855a2c760da3ac54db234ed93e3cedf6.

          RSS page is right.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                25 weeks, 3 days ago

                Development

                  Agile

                    Subcomponents