Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-46630

Site Template link-to-page pages associated with User Group do not link correctly

    Details

      Description

      Steps to reproduce:

      1. Created new Site Template called "Test ST" (this has a "home" page by default)
      2. Added regular Portlet page "pageA" to the site template
      3. Added "Link to Page" type page "pageB" that links to "pageA" to the site template
      4. Created User Group called "Test UG" with "Test ST" associated with private pages
      5. Assigned the current user to the user group
      6. Visited the user's private pages by clicking "Test Test" -> "My Dashboard", I was taken to the private home page: "http://localhost:1080/user/test/~/10491/home"
        Then I clicked on "pageB".
        RESULT: I was taken to "pageB" page of "Test UG" user group "http://localhost:1080/group/10491/pageB"
        I reproduced the issue on trunk. On 6.1.x another issue made the reproduction impossible.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              linda.sui Linda Sui
              Reporter:
              norbert.kocsis Norbert Kocsis (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 30 weeks, 4 days ago

                  Packages

                  Version Package
                  6.2.X EE
                  7.0.0 M1