Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-48015

Link to Live site does not use the live domain when defining two domains for local staging

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.1.20 EE GA2, 6.1.X EE
    • Fix Version/s: 6.1.X EE
    • Component/s: Staging
    • Labels:
      None

      Description

      Steps to reproduce / testing done / Results:
      1) Create a new site 'local-live' with a site page 'test'
      2) Under Site Settings, enable Local Live staging.
      3) Navigate to the 'local-live' Site Settings -> Site URL
      Fill in the following properties:
      Public Pages - test.com
      Staging Public Pages - staging.test.com
      4) Edit my hosts file to redirect queries to the domain to the local machine:

      127.0.0.1         test.com
      127.0.0.1         staging.test.com

      5) Navigate to the portal via test.com:8080
      6) Attempt to click the Staging tab within the dock. (It will attempt to navigate to staging.test.com:8080)
      7) Under Portal Settings -> Authentication, set to Screen Name
      8) Go to SiteMinder settings, enable SM and setup to look for SM_USER header value.
      9) Download a browser addon that modifies headers, Modify Header for firefox is an example
      10) Add new header value - SM_USER as test
      11) Enable header and attempt to login between the two environments: test.com and staging.test.com

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  6 years, 13 weeks, 1 day ago

                  Packages

                  Version Package
                  6.1.X EE