PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-48296

Web Form portlet shows field Validation options even with validation.script.enabled=false

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.10 EE GA1, 6.2.X EE, 7.0.0 M3
    • Fix Version/s: 6.2.X EE, 7.0.0 M1
    • Component/s: Web Form
    • Labels:
    • Branch Version/s:
      6.2.x
    • Backported to Branch:
      Committed
    • Story Points:
      5
    • Fix Priority:
      3
    • Similar Issues:
      Show 3 results 

      Description

      1. Start Portal
      2. Add the Web Form portlet to the default page
      3. Check the portlet's configuration for the fields and click on "Validation ยป"

      Actual Result: Validation Script can be added to the Form Fields, even though the portlet's portlet.properties contains validation.script.enabled=false by default, and the script won't be executed.
      Expected Result: Validation shouldn't appear since it has been disabled by the a property

      1. fixed.png
        21 kB
      2. reproduced.png
        36 kB

        Issue Links

          Activity

          Tibor Lipusz added a comment -

          Reproduced on master @84dc9c98d92504b12fc443e0a467fea6604af52e

          Tibor Lipusz added a comment -
          Julio Camarero added a comment -

          Just started reviewing :)

          Sent from GH.

          Hong Zhao added a comment - - edited

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0.42 + MySQL 5.5.21. Portal 62 EE SP6.
          Plugins ee-6.2.x EE GIT ID: 329df0832763b0628bc38c184ba9ff632fd3160b.

          Validation Script can be added to the Form Fields, even though the portlet's portlet.properties contains validation.script.enabled=false by default.

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: 9c9bc3718c246dc1b2ff66833cf879f99991a2ff.
          Plugins master GIT ID: 12e35cabcda88dd1d03420ba17c4582dc2cffc6f.
          Tomcat 7.0.42 + MySQL 5.5.21. Portal ee-6.2.x EE GIT ID: 59afbfb983ac652dc9b20e21d19208a72408a22f.
          Plugins ee-6.2.x EE GIT ID: 9e9a0a0eb736f779a31d4fc4a9dabd73b408e59e.

          Validation did not appear since it has been disabled by the a property.

          Hong Zhao added a comment -

          Works well if set validation.script.enabled=true, "validation" link can be seen.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved:
                Days since last comment:
                36 weeks, 6 days ago

                Development

                  Structure Helper Panel