PUBLIC - Liferay Portal Community Edition
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-48530

Cannot update portlet staging options to disable staging for portlets

    Details

    • Type: Bug Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 7.0.0 M3
    • Fix Version/s: 7.0.0 M1
    • Component/s: WCM Staging
    • Labels:
      None
    • Story Points:
      4
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      steps to reproduce

      1) enable local live staging
      2) select all portlets for staging and save
      3) uncheck a few portlets and click save

      expected behavior: the portlets will remain unchecked and the options will be saved
      actual behavior: all the portlets are still marked as staged.

      this is because of LPS-44228

      we cannot only use putAll because that only adds options; we would never remove options that are no longer selected.

        Issue Links

          Activity

          Linda Sui added a comment -

          PASSED Manual Testing following the steps in the description.

          Reproduced on:
          Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: 856f501275f1dd540bfb4b3eaa64c09d0859dae9.

          All the portlets are still marked as staged.

          Fixed on:
          Tomcat 7.0.42 + MySQL 5.5.21. Portal master GIT ID: d62f397619ac7deb59054ff4251ba47f4bd8aba7.

          The portlets remain unchecked and the options are saved.


            People

            • Assignee:
              Linda Sui
              Reporter:
              Andrew Betts
              Recent user:
              Esther Sanz
              Participants of an Issue:
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                37 weeks, 4 days ago

                Development

                  Structure Helper Panel