Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-48822

Back links are missing throughout portal when setting virtual.hosts.valid.hosts property

    Details

    • Fix Priority:
      3
    • Device Type:
      Tablet, Smartphone

      Description

      1. Set the following property to your ip address in portal.ext.properties:
        virtual.hosts.valid.hosts
        
      2. Navigate to the portal instance through the ip address
      3. Sign in
      4. Navigate to the admin> control panel> any portlets (i.e. site, users and organizations)
      5. Add new site, new user

      Actual Result: the back link to the site/users and organization home is missing.
      Expected Results: the back link to the home to be present, to match the behavior of a browser on a laptop.

      Reproduced on:
      Tomcat 7.0.42 + MySQL 5.1.35. Portal ee-6.2.x GIT ID: d90445d6d3999eb897c9a0f7c72f148736a5eb6e.
      Tomcat 7.0.42 + MySQL 5.1.35. Portal master GIT ID: 528c1562e4d3b855b6030aa1a7b17e84d99ef228.

      iPod Touch (4th Gen) + iOS 6.1.3 + Safari.
      Samsung Galaxy Nexus + Android 4.2.2 + Android Browser.
      ASUS Nexus 7 + Android 4.4.2 + Google Chrome 32.0.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              tammy.fong Tammy Fong (Inactive)
              Reporter:
              tammy.fong Tammy Fong (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                6 years, 22 weeks, 3 days ago

                  Packages

                  Version Package
                  6.2.X EE
                  7.0.0 M2