Details

    • Type: Regression Bug Regression Bug
    • Status: Closed
    • Resolution: Duplicate
    • Affects Version/s: 7.0.0 M3
    • Fix Version/s: 7.0.0 M3
    • Component/s: UI Infrastructure
    • Labels:
      None
    • Fix Priority:
      3
    • Similar Issues:
      Show 5 results 

      Description

      Steps to reproduce:

      Add Pages
      1. Navigate to Site Pages
      2. Add a Page called "parent"
      3. Click Parent page
      4. Add Child Page called "Child"
      Attempt interaction
      1. Make sure the Parent page is collapsed in the tree view
      2. Reload the page
      3. Click plus sign for Parent page to view child page

      Expected result:

      Child page should display under Parent page.

      Actual result:

      Expanding/collapsing pages in the tree does not work. User have to click the parent page in order to view child pages.

        Issue Links

          Activity

          Brian Wulbern added a comment -

          Reproduced on:
          Tomcat 7.0.42 + MySQL 5.5 Portal Master GIT ID: d62f397619ac7deb59054ff4251ba47f4bd8aba7.

          I was hitting this issue, but only when toggling between Private and Public pages in the Site Pages menu. If I approach Admin > Site Pages from the Liferay site, I don't have the issue. It's only when I am already on Site Pages that it occurs.

          Koor Gai added a comment -

          Hi Travis,
          This issue still exist on master. I was able to reproduce this following the exact steps in the description. GIT ID: d62f397619ac7deb59054ff4251ba47f4bd8aba7

          Drew Brokke added a comment -
          • If the tree-node is collapsed when one leaves the page and then navigates back, it will not properly load its children.
          • If the node is expanded (it does not matter if you can actually see the children) when leaving and returning, it will properly load the node's children.
          Drew Brokke added a comment - - edited

          Caused by AUI-1450.

          src/aui-tree/js/aui-tree-io.js, createNodes method.

          Tibor Lipusz added a comment -

          This issue duplicates LPS-48480 that is already in review at https://github.com/brunobasto/liferay-portal/pull/124

          Tibor Lipusz added a comment - - edited

          LPS-48480 will solve this issue with some others as well. Closing this as "Duplicate".

          Thanks!

          Koor Gai added a comment -

          PASSED Manual Testing following the steps in the description

          Fixed on:
          Tomcat 7.0 + Mysql 5. Portal master GIT ID: f708193c0e7f2f725abf99e31a9ed167f410dd02.

          User can now expand/collapse page.
          Fixed by LPS-48480.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                46 weeks ago

                Development

                  Structure Helper Panel