Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-49596

Web content search by ID fails when journal.article.force.autogenerate.id=false

    Details

      Description

      Issue
      Web content search by ID will not return any results when the ID is not auto-generated by set journal.article.force.autogenerate.id=false in portal-ext.properties.

      Reproduction Steps
      1. Set journal.article.force.autogenerate.id=false in portal-ext.properties
      2. Add a web content with ID = A_B_E
      3. Make sure the Title and Content doesn't contain A_B_E
      4. Save the web content and search A_B_E as the keyword (or enter value A_B_E in ID field in Advanced search)

      Actual Result: There is no search result returned
      Expected Result: The newly created web content should be returned

        Attachments

        1. fixed.png
          fixed.png
          21 kB
        2. fixed2.png
          fixed2.png
          23 kB
        3. reproduced.png
          reproduced.png
          11 kB

          Issue Links

            Activity

              People

              Assignee:
              joyce.wang Joyce Wang
              Reporter:
              laura.li Laura Li
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                7 years, 42 weeks, 5 days ago

                  Packages

                  Version Package
                  6.2.3 CE GA4
                  6.2.X EE
                  7.0.0 M2