Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-49760

WebContent structure field type document does not render children

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: 6.2.1 CE GA2
    • Fix Version/s: 7.0.0 M4
    • Component/s: ~[Archived] WCM
    • Labels:
      None
    • Story Points:
      6
    • OS:
      Windows 7
    • JDK:
      Oracle Sun JDK 7
    • Application Servers:
      Apache Tomcat 7.0
    • Browsers:
      Firefox (latest)

      Description

      When creating a WebContent structure one can add child fields to other existing fields. This usually works great but if you add a document & media field and add children like simple text field as a child, the children will not be rendered when creating a web content with this structure.

      Steps to reproduce:
      1. Create new structure "TestStructure"
      2. Add field type document&media to the form
      3. Add field type text as a child to the document&media field
      4. Save structure
      5. Create new web content by using Add>TestStructure buttons

      The text field is missing now.

      Except for this I didn't find anything related: http://www.liferay.com/de/community/forums/-/message_boards/message/38028447

        Attachments

          Activity

            People

            Assignee:
            lu.liu Lu Liu
            Reporter:
            mod David Kubitza
            Participants of an Issue:
            Recent user:
            Esther Sanz
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              6 years, 36 weeks, 2 days ago

                Packages

                Version Package
                7.0.0 M4