Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-51245

Web Form portlet's available languages don't follw the site's available languages

    Details

      Description

      Description
      If you have a site and you configure it to have only a few languages available, then the Web Form portlet doesn't follow this setup with its own language selection.
      You might be able to select a language which is not made available for the site.

      Reproduction
      1. Set in portal-ext:
      locales.enabled=ar_SA,eu_ES,bg_BG,ca_AD,ca_ES,zh_CN,zh_TW,hr_HR,cs_CZ,da_DK,nl_NL,nl_BE,en_US,en_GB,en_AU,et_EE,fi_FI,fr_FR,fr_CA,gl_ES,de_DE,el_GR,iw_IL,hi_IN,hu_HU,in_ID,it_IT,ja_JP,ko_KR,lo_LA,lt_LT,nb_NO,fa_IR,pl_PL,pt_BR,pt_PT,ro_RO,ru_RU,sr_RS,sr_RS_latin,sl_SI,sk_SK,es_ES,sv_SE,tr_TR,uk_UA,vi_VN
      2. Add a site, page to this site and the Web Form Portlet there
      3. Go to Site Administration -> Display Settings and select only a few Languages for the Current Language
      4. Go to the Web Form portlet's configuration section and see that all the portal's available languages are visible

      Expected behavior
      Only the selected few languages are visible which you set to the site.

      Reproducible on 6.2.x

        Attachments

        1. fixed.png
          fixed.png
          16 kB
        2. reproduced.png
          reproduced.png
          59 kB

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 years, 29 weeks ago

                  Packages

                  Version Package
                  6.2.3 CE GA4
                  6.2.X EE
                  7.0.0 M3