Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-51558

Submit for Publication not working for Blogs, status changes to Draft

    Details

      Description

      When creating a blog using the Single Approver workflow definition, it needs to be approved. When a blog is created it displays "Pending" which is correct. But when the blog is edited (AFTER it was approved) the "submit for publication" button won't save the blog but the blog gets the "Draft" status and not "Pending".

      1. Add the Single Approver Workflow definition to the Blog
      2. Create a new blog entry
      3. Approve the Blog entry
      4. Edit the approved blog entry and click on the "Submit for Publications" button
      5. The blog entry has a "Draft" status instead of "Pending".

      Since the entry has the draft status it cannot be approved by the Single Approver. Editing and saving it doesn't change te status.

      Found the same problem without solution here:
      https://www.liferay.com/community/forums/-/message_boards/message/32583977

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              victor.ware Victor Ware
              Reporter:
              fvoordeckers Frederik Voordeckers
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                6 years, 50 weeks, 5 days ago

                  Packages

                  Version Package
                  6.2.X EE
                  7.0.0 M1