Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-52167

Knowledge Base - Special characters are not parsed in Configuration display field

    Details

      Description

      1. Deploy Knowledge Base plugin
      2. Navigate to Admin > Content > Knowledge Base
      3. Click Add > Import
      4. Import attached zip file with markdown articles
      5. Assert imported articles are imported successfully without errors, and everything displays correctly.
      6. Add a page
      7. Add Knowledge Base Display portlet to the page
      8. Click Configuration > General > Select
      9. Choose any article or folder

      Expected results: Title of article or folder selected will persist after saving in Configuration iframe, and special characters will be parsed correctly.

      Actual results: Weird characters appear and it seems like special characters are not parsed out correctly in the field. Please see attached screenshot for more details.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 16 weeks, 4 days ago

                Packages

                Version Package
                6.2.X EE
                7.0.0 M3