Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-52192

Stacked modals aren't aligned properly after closing the last one

    Details

      Description

      Currently, in portal, if a modal that loads a uri (iframe) launches another modal that also loads a uri (iframe), when closing the last one, the first one doesn't get re-aligned correctly.

      Steps to reproduce:

      Method 1:

      1. Add a new web content.
      2. Add a Web Content Display portlet to a page.
      3. Select the new created web content to display.

      Expected result: The webcontent is displayed.
      Actual result: Fail to display the new created web content. See screenshot.

      Method 2:

      1. Add Media Gallery portlet
      2. Open portlet configuration
      3. Under Display Templates, click "Manage Display Templates for Liferay"
      4. Close Application Display Templates frame

      Expected result: Closing the frame returns user to portlet configuration frame centered on screen
      Actual result: Closing the frame returns user to portlet configuration frame on the top of the screen

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              joyce.wang Joyce Wang
              Reporter:
              joyce.wang Joyce Wang
              Participants of an Issue:
              Recent user:
              Brian Wulbern
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                6 years, 40 weeks ago

                  Packages

                  Version Package
                  7.0.0 M4