Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-52281

Adding a hyphen "-" into a DDM field label will cause errors in preview or display

Details

    Description

      Issue is fixed in master by LPS-49847 which just prevents the use of a '-' in the field.

      DESCRIPTION
      When there's a hyphen in the structure Image field name, the "Show" button doesn't display the image when editing web content

      STEPS TO REPRODUCE
      1. Add structure with an image field, give the image a name (not the label) with a hyphen in it,e.g. "Image-2999". Associate structure with a template
      2. Add content using the structure and upload an image for the field
      3. Re-open the content in edit mode and click the "show" link

      EXPECTED RESULTS
      Image would appear
      ACTUAL RESULTS
      Image does not appear and there is a javascript error

      BRANCH
      Reproduced on ee-6.2.x - 5489c7b6b13592cefb1a4f233c8ef55c61021d94

      Attachments

        Issue Links

          Activity

            People

              mark.jin Mark Jin (Inactive)
              peter.borkuti Peter Borkuti (Inactive)
              Kiyoshi Lee Kiyoshi Lee
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:
                7 years, 7 weeks, 1 day ago

                Packages

                  Version Package
                  6.2.4 CE GA5
                  6.2.X EE