Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-52451

Aui custom validator does not work properly

    Details

      Description

      Description

      The AUI custom validator is not working appropriately.

      Steps to Reproduce
      Prerequisite:

      1. Start Liferay
      2. Deploy attached .war file (portlet)
      3. Start Portal and add the validatiion portlet on the default landing page.

      Test 1

      1. Load the page with the validationbug portlet without inserting any value in the field
      2. submit the form

      Actual Result:
      -badField doesn't show any error
      -goodField show an error

      Expected Result:

      Both field should show the error

      Test 2

      1. Load the page with the validationbug portlet
      2. Input any value in both field, you will see the error in both
      3. remove all value in both field

      Actual Result:
      -badField doesn't show any error
      -goodField show an error

      Expected Result:
      Both field should show the error

      Errors/Logs

      N/A

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 years, 20 weeks, 4 days ago

                  Packages

                  Version Package
                  6.2.4 CE GA5
                  6.2.X EE
                  7.0.0 M4