Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-53520

Mentions - auto-complete should not appear when user is typing characters before @ symbol

    Details

    • Fix Priority:
      3

      Description

      Mentions portlet is making it difficult to add content that contains an @ sign (like an email address) in the fields that support mentions like blogs entry, comments, message boards, etc.

      Steps to Reproduce:

      1. Deploy Mentions portlet
      2. Add Blogs Portlet
      3. Add Blogs Entry
      4. Try to enter "Please email me at test@test.com"
      5. Assert the autocomplete for mentions appears after '@t' is entered.

      Expected Result:
      Mentions Auto Complete shouldn't display if the '@' is in the middle of characters (like an email address). It might be better to have it display only if it is following a space or the very first character of a line and not in the middle of content.

      Actual Result:
      @ is used to pull up mentions regardless of where the symbol is located.

        Attachments

          Activity

            People

            • Assignee:
              sylvia.luan Sylvia Luan
              Reporter:
              simon.park Simon Park (Inactive)
              Participants of an Issue:
              Recent user:
              Esther Sanz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 17 weeks, 4 days ago

                Packages

                Version Package
                6.2.X EE
                7.0.X EE
                Master