Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-54928

Knowledge Base - Attachments show up as saved and pending to be saved

    Details

      Description

      Knowledge Base Articles aren't fully saving attachments when publishing the article. In ee-6.2.x the article will publish, and then editing the article will display the attachments as both saved and pending to be saved.

      In ee-6.2.10 and master, the article is saved and there is no notice to save the attachment.

      Steps to Reproduce:

      1. Go to Admin, Content, Knowledge Base
      2. Select Add Article
      3. Enter Title, Content
      4. Add Attachment (exceeding 100mb in size)
      5. Select Publish
      6. Edit the Article that was just created
      7. Assert that the attachment is both saved and pending to be saved.

      Expected Result:
      The attachment is saved to the page.

      Actual Result:
      The attachment displays both in the saved and under a warning about needing to be saved or deleted.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                simon.park Simon Park (Inactive)
                Reporter:
                simon.park Simon Park (Inactive)
                Participants of an Issue:
                Recent user:
                Esther Sanz
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 years, 35 weeks, 1 day ago

                  Packages

                  Version Package
                  6.2.4 CE GA5
                  6.2.X EE