Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-55231

Encoding errors when answering a Restricted Site's Membership Request

    Details

      Description

      Reproduction steps:

      1. start a liferay bundle
      2. log in as omniadmin
      3. Configure a site "test1" as restricted membership
      4. Add a public page (called: testpage) to site "test1"
      5. Add "my sites" portlet on site "test1"
      6. Create another admin user
      7. With the other user go to the site (http://localhost:8080/web/test1/testpage)
      8. On the my site portlet, go to available sites
      9. Click "request membership" on "test1" row
      10. Fill user comments with : " ' & " (apostrophe and ampersand)
      11. Send request
      12. With the first user go to "view membership requests" in site membership (control panel)
      (The request is there, the comment is OK)
      13. Click "reply"

      expected result: In the text area, the user comment is

       ' & 

      actual result: In the text area, the user comment is

       ' & 

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Due:
                  Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 years, 29 weeks, 5 days ago

                  Packages

                  Version Package
                  7.0.0 M5