Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-55905

Upgrade Plugins SDK JSF portlet templates to Liferay Faces 3.2.5-ga6 and associated dependencies

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Inactive
    • Affects Version/s: 6.2.3 CE GA4, 7.0.0 M5
    • Fix Version/s: None
    • Labels:
      None

      Description

      Similar to MAVEN-151, this task involves modifying the Liferay Faces dependencies to 3.2.5-ga6 in the following ivy.xml descriptors in the Plugins SDK:

      tools/templates/portlet_icefaces_tmpl/ivy.xml
      tools/templates/portlet_jsf_tmpl/ivy.xml
      tools/templates/portlet_liferay_faces_alloy_tmpl/ivy.xml
      tools/templates/portlet_primefaces_tmpl/ivy.xml
      tools/templates/portlet_richfaces_tmpl/ivy.xml

      In addition, all other dependencies like Mojarra (upgraded to 2.1.29-03 in FACES-2242), PrimeFaces (upgraded to 5.2 in FACES-2179) and RichFaces (upgraded to 4.5.5.Final in FACES-2224) should be upgraded as well.

        Attachments

          Issue Links

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  4 years, 23 weeks, 3 days ago

                  Packages

                  Version Package