Uploaded image for project: 'PUBLIC - Liferay Portal Community Edition'
  1. PUBLIC - Liferay Portal Community Edition
  2. LPS-57606

TemplateModelException when attempting to add Web content

    Details

      Description

      Steps to reproduce:
      1. Login as admin and go to Admin -> Content and create a structure with a selection list.
      2. Go to the source and modify predefinedValue meta-data entry to contain a number instead of a string. On 6.2 the source would look like this:

      <?xml version="1.0" encoding="UTF-8"?>
      <root>
      <dynamic-element name="LinkType" type="list" index-type="" repeatable="false">
      	<meta-data>
      		<entry name="predefinedValue"><![CDATA[1]]> </entry>
      	</meta-data>
      
      <dynamic-element name="Internal" type="1" index-type="" repeatable="false"></dynamic-element>
      </dynamic-element>
      </root>
      

      3) Link a dummy blank template to it
      4) Try to add a web content from such structure

      Result: TemplateModelException is thrown. Please see the full stacktrace in the attached TemplateModelException.log file.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              felix.zhang Felix Zhang
              Reporter:
              laszlo.hudak Laszlo Hudak
              Participants of an Issue:
              Recent user:
              Esther Sanz
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                4 years, 6 weeks, 1 day ago

                  Packages

                  Version Package
                  6.2.X EE
                  7.0.0 M7